Buf - Some commits unavailable on buf.build – Incident details

Some commits unavailable on buf.build

Resolved
Degraded performance
Started over 2 years agoLasted about 2 hours

Affected

buf.build

Degraded performance from 2:00 PM to 3:45 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    Engineers have identified the root cause to be a deploy which does not correctly retrieve some commits. No data loss has occurred and engineers are working on a fix

  • Investigating
    Investigating

    We have received reports that some commits seem to have disappeared from buf.build, engineers are investigating.